EsmaVaida
31.05.2022 15:31

Составить программу в паскаль. вывести на экран произведение первых 20-ти натуральных чисел. нужно. заранее ! )

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Ksenyukn
08.10.2020 23:50

Типа double должно хватить под это все дело.

В целочисленные типы такое число, увы, не влезет.

var

   i:integer;

   result:double;

begin

   result := 1;

   for i := 2 to 20 do

       result := result * i;

   writeln('Результат = ', result);

end.

0,0(0 оценок)
Ответ:
prokopchukalex
08.10.2020 23:50

// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018


begin

 Range(1,20).Aggregate(biginteger(1),(p,x) -> p*x).Println;

end.


ответ =  2432902008176640000

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота