Aann1
24.04.2023 00:17

Нужно написать программу, которая переводит десятичные числа в двоичные. на языке паскаль. !

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lera1060
21.08.2020 17:00

// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018

// Внимание! Если программа не работает, обновите версию!

begin

 var n := ReadInteger('Введите натуральное десятичное число:');

 var r: string := '';

 while n >= 2 do

   (r, n) := (n mod 2 + r, n shr 1);

 r := '1' + r;

 r.Println

end.

0,0(0 оценок)
Ответ:
Santastiff666
21.08.2020 17:00

Program l;

var

n: integer;

s: String;  

begin  

readln(n);  

while n>0 do begin  

insert(chr(48+n mod 2),s,1);  

n:=n div 2;  

end;  

writeln(s);  

end.


Нужно написать программу, которая переводит десятичные числа в двоичные. на языке паскаль. !
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота