крутой1337228
02.04.2023 02:54

Написать на си . составить программу, формирующую одномерный массив, со- стоящий из n целых элементов. вычислить сумму положительных элемен- тов массива. определить количество элементов, имеющих четные поряд- ковые номера и являющиеся нечетными числами. упорядочить элементы массива по возрастанию.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
danilpov
27.08.2020 08:16

Важное замечание: Программа будет работать только при компиляции компилятором, поддерживающим стандарт C99.

#include <stdio.h>

#include <stdlib.h>


int compare(const int* A, const int* B); // компаратор для qsort

int main()

{

   int N;

   

   printf("Введите размер массива: ");

   scanf("%d", &N);

   

   int

       arr[N],

       sum = 0,

       number = 0;

   

   

   for(int i = 0; i < N; i++)

       scanf("%d", &arr[i]);

       

   for(int i = 0; i < N; i++)

       printf("%d ", arr[i]);

   printf("\n");

   for(int i = 0; i < N; i++)

   {

       if(arr[i])

           sum += arr[i];

       if((arr[i] % 3 == 0) && (i % 2 == 0))

           number += 1;

   }

   

   qsort(arr, N, sizeof(int), compare);

   

   for(int i = 0; i < N; i++)

       printf("%d ", arr[i]);

   

   

   printf("\nСумма положительных элементов = %d\n\

   количество элементов, имеющих четные порядковые номера и являющиеся нечетными числами = %d", sum, number);

   return 0;

}


int compare(const int* A, const int* B)

{

   return *A - *B;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота