LollyPopsi
05.06.2021 18:08

Написать программу с++, создать матрицу, заполнить рандомными числами,найти максимальный элемент в главной диагонали

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
KIMSEOLHYUN
08.10.2020 23:10

#include <iostream>

#include <cstdlib>

#include <ctime>

int main()

{

   int N;

   

   std::cout << "Введите количество строк и столбцов(N): ";

   std::cin >> N;

   

   //выделяем память

   int** arr = new int* [N];

   for(int i = 0; i < N; i++)

       arr[i] = new int [N];

   

   srand(time(NULL));//рандомизация

   

   std::cout << "Матрица имеет вид: " << std::endl;

   //заполняем массив случайными числами

   for(int i = 0; i < N; i++)

   {

       for(int j = 0; j < N; j++)

       {

           arr[i][j] = 1 + rand() % 100; // от 1 до 100

           std::cout << arr[i][j] << " ";

       }

       std::cout << std::endl;

   }

   

   //ищем максимальное число

   int max = arr[0][0];

   for(int i = 0, j = 0; i < N, j < N; i++, j++)

   {

       if(arr[i][j] > max)

           max = arr[i][j];

   }

   

   std::cout << std::endl << "Наибольшее число на главной диагонали: " << max;

   

   //удаляем память

   for(int i = 0; i < N; i++)

       delete[] arr[i];

   delete[] arr;    

   

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота