Djdjjdjdjdjddjjx
28.11.2020 16:41

Написать программу в паскале автобус провозит 50 пассажиров. из них 10 едут до первой станции, 20 - до второй, а остальные до конечной. стоимость билетов до каждой станции соответственно равна a,b,c. определите сколько рейсов должен делать автобус. чтобы выручка составила к руб?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MariaUt
08.10.2020 22:55

var a, b,c,k,d,e,g,h : integer;

var f : integer;

begin

writeln('Введите стоимости билета за проезд до первой, до второй и до конечной станции через пробел :');

readln(a,b,c);

writeln('Введите сколько рублей должна быть конечная выручка : ');

readln(k);

d := 10*a;

e := 20*b;

g := 20*c;

h := d+e+g;

f := h div k;

writeln(f, ' Рейсов нужно совершить нужно совершить.');

end.

Лог :

Введите стоимости билета за проезд до первой, до второй и до конечной станции через пробел :

1

1

1

Введите сколько рублей должна быть конечная выручка :  

50

1 Рейсов нужно совершить нужно совершить.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота