арина1494
16.06.2020 11:19

Составить блок схему и написать программу на языке с++. с цикла определите является ли сумма цифр введенного натурального числа четной или нечетной.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
zeynab122
08.10.2020 22:04

#include <iostream>

int main() {

   std::string s;

   int S = 0;

   std::cin >> s;

   for (int i=0; i<s.length(); i++){

       S += int(s[i]-'0');

   }

   std::cout<<(S%2?"Odd":"Even");

   return 0;

}

Объяснение:


Составить блок схему и написать программу на языке с++. с цикла определите является ли сумма цифр вв
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота