Mашka
01.12.2020 03:30

Написать программу, которая запрашивает слово и проверяет, является ли это слово палиндромом. pascal abc

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Natashazzz
08.10.2020 21:14

var

    s: string;


function Invert(s: string): string;

var

    i: integer;

    t: string;

begin

    t := '';

    for i := 1 to length(s) do

        t := s[i] + t;

    

    Invert := t;

end;


begin

    Write('Введите слово: ');

    Readln(s);

    

    s := Trim(s);

    s := Uppercase(s);

    

    if Invert(s) = s then 

        Writeln('Палиндром')

    else 

        Writeln('Не палиндром');

end.

0,0(0 оценок)
Ответ:
ElinaN28
08.10.2020 21:14
Var
  s:string;
  i,n:byte;
  p:boolean;
begin
  Write('Введите слово: ');
  Readln(s);
  n:=Length(s);
  p:=true;
  for i:=1 to n div 2 do
    if s[i]<>s[n-i+1] then
    begin
      p:=false;
      break
    end;
  if p then Writeln('Палиндром')
  else Writeln('Не палиндром')
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота