2004080111
13.03.2022 18:48

Составить программу, которая будет считывать введённое четырехзначное число. каждую цифру этого числа необходимо вывести в новой строке

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Nyoken
16.08.2020 22:51
// PascalABC.NET

begin
   var num: integer;
   while true do
   begin
      num := ReadlnInteger('введите 4-х значное число, num =');
      if (num > 999) and (num <= 9999)
         then break;
   end;
   
   var str := num.ToString;
   
   foreach var x in str do
      Println(x)
end.
0,0(0 оценок)
Ответ:
Yulduzka28
16.08.2020 22:51
Var a,f:integer;
begin
write('Введите четырехзначное число: ');
readln(a);
f:=a div 1000;
writeln(f);
a:=a-1000*f;
f:=a div 100;
writeln(f);
a:=a-100*f;
f:=a div 10;
writeln(f);
a:=a-10*f;
writeln(a);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота