Войти
Регистрация
Спроси ai-bota
197983
16.09.2021 11:08
Написать программу на языке c++, которая создает и выводит 2x2 квадратную матрицу на экран. после того как матрица появилась на экране, программа должна посчитать её определитель.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
дархан23
19.07.2021 12:04
Сендер дүкенде кеңесші болып істейсіңдер делік. Сатып алушыларға қандай процессоры бар компьютер алуға кеңес берер едіңдер? Процессор туралы ақпаратты іздеу үшін Интернет желісін...
xezi1
25.01.2020 22:09
Ернур и Серикбол обсуждают новости каждый день перед уроками. Но Ернур уехал в аул к бабушке на летние каникулы друзьям обсуждать новости независимо от расстояния, выбери подходящие...
angel32b
13.05.2022 02:17
Әлемдегі алғашқы бағдарламашы әйелдің есімі – Ада Лавлейс үш тәсілмен кодталған. Берілген есімнің ақпараттық салмағы Х алфавитінде – 11 байт, У алфавитінде – 22 байт, ал Z алфавитінде...
rachik141516
04.06.2021 21:23
1) Разверни числа:а) 81 б) 524 в) 341,6г) 89,11...
vika20022003
27.05.2023 08:56
Что из перечисленного является источником информации? Пенал, книга, ручка, ластик. ...
Freewomans
24.11.2021 20:51
Сколько периодов в истории развития вычислительной техники?...
vika03121
11.05.2023 09:21
Найдите в интернете законы, указы, решения, касающиеся правил компьютерной этики...
gulya19860630
02.10.2020 16:28
Объясните схему перевода одних едениц измерения в другое...
anzhelikamilan
26.02.2023 06:08
Выберите верное имя файла 1фото файла 2 доклад по информатике 3 рисунок...
aushatsy
06.01.2021 09:19
W -ответы на вопросКакая была масса первого многозадачного компьютера ENIAC?...
Ответ:
nikzyk
08.10.2020 21:05
#include <iostream>
#include <time.h>
using namespace std;
int main() {
setlocale(0, "RUS");
srand(time(NULL));
int matr[2][2];
cout << "Сгенерированная матрица:" << endl;
for (int i = 0; i < 2; i++) {
for (int j = 0; j < 2; j++) {
matr[i][j] = rand() % 10;
cout << matr[i][j] << " ";
}
cout << endl;
}
cout << "Определитель матрицы: " << matr[0][0] * matr[1][1] - matr[0][1] * matr[1][0] << endl;
system("pause");
}
0,0
(0 оценок)
Ответ:
Анара2000
08.10.2020 21:05
#include <iostream>
#include <vector>
int main()
{
std::vector<std::vector<size_t>> v2d = { { 5, 4 }, { 3, 5 } };
for (const auto& i : v2d)
for (const auto& j : i)
std::cout << j;
std::cout << v2d.at(0).at(0) * v2d.at(1).at(1) - v2d.at(0).at(1) *
v2d.at(1).at(0);
}
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота