1Аминка
31.10.2021 20:49

Нужно написать программу на паскале: в матрице размера m×n положительные элементы заменить единицей. создание и вывод матриц оформить в виде процедур.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
21VR
16.08.2020 22:48
PascalABC.NET 3.4.0, сборка 1675 от 12.06.2018
Внимание! Если программа не работает, обновите версию!

procedure MatrixCreate(m,n:integer; var A:array[,] of integer);
begin
  A:=MatrRandom(m,n,-50,50);
end;

procedure MatrixOutput(A:array[,] of integer);
begin
  A.Println(4)
end;

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в матрице:');
  var a:array[,] of integer;
  MatrixCreate(m,n,a);
  Writeln('*** Исходная матрица ***');
  MatrixOutput(a);
  a.Transform(t->t>0?1:t);
  Writeln('*** Полученная матрица ***');
  MatrixOutput(a);
end.

Нужно написать программу на паскале: в матрице размера m×n положительные элементы заменить единицей.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота