Савина11
31.01.2022 14:36

Напишите программу, которая о трех числа решает могут ли они быть сторонами прямоугольного треугольника. напишите программу так чтобы любое число могло быть гипотенузой. паскаль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
uhbujhxbr
08.10.2020 20:51
PascalABC.NET 3.4.0, сборка 1671 от 31.05.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadSeqInteger('Введите стороны прямоугольника',3).Sorted.ToArray;
  if Sqr(a[2])=Sqr(a[0])+Sqr(a[1]) then Writeln('Могут')
  else Writeln('Не могут')
end.

Напишите программу, которая о трех числа решает могут ли они быть сторонами прямоугольного треугольн
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота