SlavaArt
19.09.2020 18:04

Составить программу для : ввести трехзначное число, и вывести через запятую его отдельные цифры.pascal

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Gunterio
08.10.2020 20:28
PascalABC.NET 3.4.0, сборка 1670 от 23.05.2018
Внимание! Если программа не работает, обновите версию!

1. Самое простое "арифметическое" решение

begin
  var n:=Abs(ReadInteger('n=')); // защита от отрицательных чисел
  Writeln(n div 100,',',(n div 10) mod 10,',',n mod 10)
end.

Пример
n= 318
3,1,8

2. "Арифметическое" решение с циклом, цифры в обратном порядке

begin
  var n:=Abs(ReadInteger('n=')); // защита от отрицательных чисел
  while n>10 do begin
    Write(n mod 10,',');
    n:=n div 10
    end;
  Writeln(n mod 10)
end.

Пример
n= 318
8,1,3

3. "Арифметическое" решение с массивом

begin
  var n:=Abs(ReadInteger('n=')); // защита от отрицательных чисел
  var a:array[1..3] of integer;
  var i:=3;
  while n>0 do begin
    a[i]:=n mod 10;
    i-=1;
    n:=n div 10
    end;
  Writeln(a[1],',',a[2],',',a[3])
end.

Пример
n= 318
3,1,8

4. Решение с символьной строкой

begin
  Abs(ReadInteger('n=')).ToString.ToCharArray.Println(',')
end.

Пример
n= 318
3,1,8
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота