JamesBond007007007
17.12.2021 00:56

Решить на c напишите программу, позволяющую сравнить две обыкновенные дроби. ввод на ввод подается четыре целых положительных числа (все числа не превышают 10000 ): в первой строке числитель и знаменатель первой дроби, во второй строке числитель и знаменатель второй дроби. вывод если первая дробь меньше второй, выведите ‘< ’, если дроби равны, выведите ‘=’, если первая дробь больше второй,выведите ‘> ’.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Karlik777
08.10.2020 19:29
Using System;
namespace Fractions{    public struct Fraction : IComparable<Fraction>    {        public Fraction(int numerator, int denominator)        {            Numerator = numerator;            Denominator = denominator;        }
        public int Numerator;        public int Denominator;
        public int CompareTo(Fraction other)        {            return (Numerator * other.Denominator).CompareTo(other.Numerator * Denominator);        }    }
    public class Program    {        static void Main(string[] args)        {            int numerator, denominator;
            Console.Write("Числитель первой дроби ");            numerator = int.Parse(Console.ReadLine());            Console.Write("Знаменатель первой дроби ");            denominator = int.Parse(Console.ReadLine());            var fraction1 = new Fraction(numerator, denominator);
            Console.Write("Числитель второй дроби ");            numerator = int.Parse(Console.ReadLine());            Console.Write("Знаменатель второй дроби ");            denominator = int.Parse(Console.ReadLine());            var fraction2 = new Fraction(numerator, denominator);
            var compareResult = fraction1.CompareTo(fraction2);            if (compareResult < 0)                Console.WriteLine("<");            else if (compareResult > 0)                Console.WriteLine(">");            else // = 0                Console.WriteLine("=");        }    }}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота