наргиз68
11.08.2022 11:45

Напишите программу в pascal дано трехзначное число х. если х-четное число, то вычислить сумму цифр этого числа. если х-нечетное, то вычислить число-перевертыш

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Zhurenko13
08.10.2020 19:29
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  var (s,d,e):=(n div 100, n div 10 mod 10,n mod 10);
  if n.IsEven then Writeln(s+d+e) else Writeln(e,d,s)
end.

Примеры
n= 531
135

n= 428
14
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота