juliana123456
22.04.2023 14:20

Составьте программу для решение следующей . введите с клавиатуры три числа. если все числа отрицательны и не равны между собой, то замените числа их квадратами, иначе найдите и выведите сумму этих чисел. выведите результаты на экран. хелп, паскаль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Кукарику12
08.10.2020 19:05
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadReal3;
  if (a<>b) and (a<0) and (b<0) and (c<0) then begin
    (a,b,c):=(a*a,b*b,c*c);
    Println(a,b,c)
    end
  else Writeln('Сумма равна ',a+b+c)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота