лейла1102
28.04.2023 21:09

С! составить программу в паскале 1. найти сумму нечетных чисел в промежутке от 20 до n

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Берем первое нечетное в этом диапазоне (21) и прибавляем к нему все числа через одно (т.е. тоже все нечетные), пока не выйдем за пределы n.

PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  Writeln('S=',Range(21,ReadInteger('n='),2).Sum)
end.

Пример
n= 250
S=15525
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота