Babetta51
20.01.2023 12:28

50 !
программисты, ! во для решения на с++
вводится n натуральных чисел. найти минимальное, кратное 7. если такого числа нет, вывести "нет".
объясните , как сформулировать условие для вывода "нет"

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ekaterina2206
07.05.2020 07:59

// Массив из "a" заполнил псевдорандомными числами от 0 до 3 для наглядности

using System;

namespace ConsoleApp1

{

   internal class Program

   {

       private static void Main()

       {

           const int numsCount = 24;

           const int resCount = 10;

           double[] nums = new double[numsCount];

           double[] res = new double[resCount];

           var rand = new Random();

           for (int i = 0; i < numsCount; i++)

           {

               nums[i] = rand.Next(0, 4);

               Console.WriteLine($"a[{i}] = {nums[i]}");

           }

           Console.WriteLine();

           for (int i = 1; i <= resCount; i++)

           {

               double sum = 0;

               for (int j = 0; j < numsCount; j++)

                   sum += Math.Pow(nums[j], i);

               res[i - 1] = sum;

               Console.WriteLine($"b[{i - 1}] = {sum}");

           }

           Console.ReadLine();

       }

   }

}


Нужно написать программу в с# либо исправить мой код, который работает некорректно, Все как в услови
Нужно написать программу в с# либо исправить мой код, который работает некорректно, Все как в услови
0,0(0 оценок)
Ответ:
Лідія200445
11.06.2021 08:06
//1a

Var
 i,x1,x2:integer;
begin
 for i:=10 to 99 do
  begin
   x1:=i mod 10;
 x2:=i div 10;
   if (sqr(x1)+sqr(x2)) mod 13=0 then writeln(i);
  end;
end.

//1б
Var
 i,x1,x2:integer;
begin
 for i:=10 to 99 do
  begin
   x1:=i mod 10;
   x2:=i div 10;
   if x1+x2+sqr(x1+x2)=i then writeln(i);
  end;
end.

//2
Var
 i,n,a,k1,k2:integer;
begin
 readln(n);
 for i:=1 to n do
  begin
   readln(a);
   if a<1985 then k1:=k1+1;
   if a>1990 then k2:=k2+1;
  end;
 writeln('Родившиеся до 1985:',k1);
 writeln('Родившиеся после 1990:',k2);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота