mkm3
06.03.2020 04:55

Составить программу по условию: дан массив из 10 элементов.найти сумму элементов, кратных 3 и двузначных. массив задан случайно на паскале

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
soktomunkuev20
27.08.2020 06:46

Так как задание не формализовано выводит последовательно суммы кратных 3 и двухзначных чисел

Program TZ5;
const
n=10;
var
a:array [1..n] of integer;
i,b:integer;
begin
randomize;
for i:=1 to n do begin
 a[i]:=random (20);
 a[i]:=a[i]-10;
        writeln(i,'  ',a[i]);
end;
b:=0;
for i:=1 to n do
    if (a[i] mod 3)=0 then
       b:=b+a[i];
writeln('summa kratnyh 3m=',b);
b:=0;
for i:=1 to n do
    if abs(a[i]) >9 then b:=b+a[i];
writeln('summa dvuhznachnyh =',b);
readln;
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота