Artemkotkot20
05.11.2021 21:05

Используя признаки делимости, написать программу в паскале, которая проверяет, делится ли натуральное число k на 4 (две последние цифры нули или образуют число, делящееся на 4).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
данилка125
10.09.2020 15:58
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var k:=ReadInteger('n=');
  var a:=k mod 10; // поледняя цифра
  var b:=(k mod 100) div 10; // предпоследняя цифра
  if (a=0) and (b=0) or ((10*b+a) mod 4=0) then Writeln('Делится на 4')
  else Writeln('Не делится на 4')
end.

Пример
n= 567264
Делится на 4
0,0(0 оценок)
Ответ:
cracavica211220
10.09.2020 15:58
Program qwerty;
var k, a:integer;
begin
readln(k);
a:=k mod 100;
if(a=0) or (a mod 4=0) then write('Да')
else write('Нет')
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота