oksana1111156970
10.03.2021 10:27

Составить программу, проверяющую, является ли заданное натуральное число совершенным, т.е. равным сумме своих положительных делителей, кроме самого этого числа. на с++, с цикла с предусловием или постусловием.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Папинадочка111
08.10.2020 14:42
#include <iostream>
using namespace std;
int main(){    int i, num, sum;        sum = 0;    i = 1;    cin >> num;    while (i < num)    {        if (num % i == 0)        {            sum += i;        }        i++;    }    if (sum == num) {        cout << sum;    }    return 0;}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота