роман507
08.04.2021 18:32

Составить программу вычисления среднего арифметического значение четных по значению элементов массива. элементы нумеруются с 0 до 49 и с датчика случайных чисел из диапазона [0,300]

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Kurbatovaolga15
08.10.2020 14:38
Var a: array[0..49] of Integer; sr:real;sum,i,n: integer;beginwriteln('Исходный массив');for i:=0 to 49 do begina[i]:=Random(300);write(a[i]:4);if a[i] mod 2 = 0 then begin sum:= sum + a[i]; n:= n +1; end;end;sr:= sum / n;writeln;writeln('Cреднее арифметическое значение четных ',sr);end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота