Meshnyakova52
07.12.2022 06:22

На ! написать программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 2. программа получает на вход натуральные числа, количество введённых чисел неизвестно,последовательность чисел заканчивается числом(0-признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа не превышают 30000. программа должна вывести одно число: сумму всех чисел кратных 6 и оканчивающихся на 2. также надо составить блок-схему, контрольные примеры, написать порядок выполнения работы. нужен точный ответ и правильный.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
sodzirovna
10.09.2020 15:55
1. Примерно так учат писать программы в большинстве школ

var
  n,s:integer;

begin
  s:=0;
  repeat
    Read(n);
    if n<>0 then
      if (n mod 6=0) and (n mod 10=2) then s:=s+n
  until n=0;
  Writeln(s)
end.

Пример
16
42
18
132
94
18
0
174

Кроме этого, зачем-то требуют блок-схему  - приведена во вложении, выполнена по ГОСТ 19.701-90 (ISO 5807-85).

2. А вот так эту задачу можно решить в современном Паскале

PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  ReadSeqIntegerWhile(t->t<>0)
      .Where(t->(t mod 6=0) and (t mod 10=2)).Sum.Println
end.

И блок-схема тут вообще не нужна: она ничего не даст.

Сравнение явно не в пользу школьного "образования" - учить, как выполнять работу двадцать минут вместо двух.

На ! написать программу, которая в последовательности натуральных чисел определяет сумму всех чисел,
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота