Nina2111
24.01.2022 16:24

Составить программу, которая для любого натурального числа печатает на естественном языке количество цифр в записи этого числа.составить программу на паскале.!

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Екатерина2088
08.10.2020 14:41
Var
a:real;
begin
WriteLn('Введите чтсло');
readln(a);
Write('В записи этого числа ');
case a of
1..9 : Write ('одна цифра');
10..99 : Write ('две цифры');
100..999 : Write ('три цифры');
1000..9999 : Write ('четыре цифр');
10000..99999 : Write ('пять цифр');
100000..999999 : Write ('шесть цифр');
else Writeln('Данное число слишком велико');
end;
end.
0,0(0 оценок)
Ответ:
VladimirLK
08.10.2020 14:41
Var a:uint64;
k:Integer;
begin
write ('Введите число: ');
readln (a);
repeat
k:=k+1;
a:=a div 10
until a=0;
writeln('Количество цифр: ',k)
end.

var a:string;
begin
write ('Введите число: ');
readln (a);
writeln('Количество цифр: ',Length(a))
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота