РенатаG
28.04.2021 23:10

Составить программу вычисления произведения положительных и суммы отрицательных элементов массива a.проверить работу программы на заданном массиве a(11). на паскале

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
milaboit
08.10.2020 14:23
Program p1;
uses crt;
var a:array[1..11] of integer;
i,p,s:integer;
begin

for i:=1 to 11 do begin
 a[i]:=random(30)-10;
 write(a[i]:4);
 end;
    p:=1;
 s:=0;
  for i:=1 to 11 do begin

    If a[i]>0 then begin
      p:=p*a[i];
     end;
     
     If a[i]<0 then
      s:=s+a[i];
      end;
writeln;
writeln('Произведение  :',p);
writeln('Сумма :',s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота