Ulysses228
28.06.2020 18:17

Составить программу вычисления суммы элементов массива а, значения которых меньше чем -0,5. проверить работу программы за заданном массиве а(11). паскаль

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lenaldld
08.10.2020 14:05
Var
a: array[1..100] of real;
i,n:Integer;
sum: real;
begin
WriteLn('Введите количество элементов массива');
Readln(n);
WriteLn('Массив');
for i:=1 to n do
begin
a[i]:=(random(100)-50)/10;
Write(a[i]:5);
if a[i]< -0.5 then sum:=sum +a[i];
end;
Writeln;
Writeln('Сумма элементов меньших -0,5 = ', sum);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота