никотян7
13.03.2020 20:17

Решать в pascal найти наибольший элемент заданной целочисленной числовой последовательности. входные данные: во входном потоке в первой строке задано натуральное число n (n < = 1000) - количество элементов числовой последовательности. во второй строке через пробел перечислены значения элементов последовательности ai (-32000 < = ai < = 32000). выходные данные: в выходной поток вывести единственное целое число. пример входного файла (input.txt): 8 100 10 -10 -100 300 32000 20000 -30000 пример выходного файла (output.txt): 32000 мое решение(ошибку скажите): var a,b,max,i: longint; begin read(a); for i: =1 to a do begin read(b); if b> =max then max: =b; end; write(max); end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Муся000
08.10.2020 13:31
Ошибка заключается в том, что переменную max нужно инициализировать прежде, чем будет осуществлен вход в цикл.

var a, b, max, i : longint;
begin
  read(a);
  max := -32001;
  for i:=1 to a do begin
  read(b);
  if b >= max then 
    max:=b;
  end;
  write(max);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота