olga837
26.01.2022 16:30

Написать программу в с++. задан двумерный массив y из 7-и строк и 3-х столбцов. составить программу, которая вычисляет значение суммы произведений элементов строк

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
tatyana101035
08.10.2020 13:30
#define N 7
#define M 3
#include <iostream>
using namespace std;
int main() {   
    float Y[N][M];
    // Ввод данных
    for (int i = 0; i < N; i++)
        for (int j = 0; j < M; j++)
            cin >> Y[i][j];

    float sum = 0, prod = 0;
    for (int i = 0; i < N; i++) {
        prod = 1;
        for (int j = 0; j < M; j++) {
            prod *= Y[i][j];
        }
        sum += prod;
    }
    cout << "Sum: " << sum << ".\n";
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота