olya0611
09.04.2022 18:09

Составить программу по информатике.
вычислить разделение положительных чисел которые вводятся с клавиатуры используя оператор repeat. заранее огромное .​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
илопор
22.12.2021 21:51

24. 1)заголовок программы

2)блок описания используемых программ

3)блок описания действий по преобразованию данных (программный блок)

25. program <имя программы>;

const <список постоянных значений>;

var <описание используемых переменных>;

begin <начало программного блока>

<оператор 1>;

<оператор 2>;

...

<оператор n>

end.

26. <имя переменной>:=<выражение>

27. write(b1, b2,...bk)

writeln(b1, b2,..,bk)

28. read(b1, b2,..bk)

readln(b1,b2,...,bk)

Надеюсь, что чем-то

0,0(0 оценок)
Ответ:
Darwin111
22.12.2020 09:05

Поскольку ДКР , то я просто объясню как решать все задания

1)Просто присваивание,каждый раз присваиваем новое значение

оператор div - это вычисление целого значения числа.

a:=42 div 14=3 (поскольку при делении 42 на 14 ,целое число-это 3,без остатка)

2)То же самое только тут операторы if/then/else

<if>-<если>;<then>-<тогда>;<else>-<иначе> (онли перфект инглишШ*:))

В твоей задаче так: Если a>b , то c:=3*b... иначе(если a<b) c:=3*a...(otvet: -15)

3)Ну оператор while -выполнение цикла до тех пор пока условие верно .Типо x:=x-3 and y:=y*x будет выполняться до тех пор пока x>5

4)В этом задании ответ 1 (в 1 двух столбиках: 1-означает истина;0-означает ложь),третий граф проверяет значение ЛОЖЬ.

1-0 и 0 =0

2-0 и 1 =0

3-1 и 0 =0

4-1 и 1=0 ,&- для выполнения все значения должны быть истиной,если бы 1 и 0=1 ,то это было бы v поскольку для этого требуется 1-а истина

5)231 в двоичную итс из изи май френд.Делим 231 на 2 до тех пор пока  не дойдем до 1.Если число четное ,то 0 ,если нет то 1.  231(1)115(1)57(1)28(0)14(0)7(1)3(1)1(1) затем записываем начиная с последнего -11100111

6)100110 в десятичную тоже не сложно нумеруем все числа слева направо начиная с 0.Потом умножаем числа на 2 с степенью номера числа:1*2^5+1*2^2+1*2=32+4+2=38

7)С кругами Эйлера тут будет в эл.виде сложно,но я постараюсь

Шахматы&Шашки =14000

Шахматы =16000

ШахматыlШашки =20000

Из 2 и 3 строчек мы понимаем ,что чистый кусочек шашки = 4 т.

Чтобы найти пересечение мы из 16000 отнимаем 14000 и получаем 2000 и из этого можно сделать вывод что Шашки=6т

Короче я старался чисто для тебя:)Оцени поставь лайк ,коммент ,в топ завези:)Удачи

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота