aromishka
17.09.2021 12:08

Яне понимаю в программировании. имеется , решенная в turbo pascal. нужен алгоритм ее решения, т.е. расписать какая операция что делает и сколько всего операций. : напишите программу для проверки, есть ли в данном слове буква «а». если есть, то найдите номер первой из них. решение: var a: string; var i: integer; begin writeln('введите слово'); read(a); for i: =1 to length(a) do begin if (a[i]='а') then begin writeln('найдена буква “а”, ее позиция: ' , i); break; end; end; end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
azharabikenova
08.10.2020 13:27
Алгоритм решения следующий:

Сначала считывается введенное слово в переменную. Далее, в цикле от начала слова и до его конца проверяется, является ли текущая буква, равной искомой, то есть букве "а". Если такая буква найдена, то выводится её позиция в слове.

А теперь комментарий по каждой из строчек кода.

// Блок объявления переменных
var a:string; 
var i:integer;
// Начало программы
begin
// Ввод слова
writeln('Введите слово');
// Считывание слова
read(a);
// Цикл от 1 до длины считанного слова
for i:=1 to length(a) do begin
// Условие на то, является ли текущая буква заданной
if (a[i]='а') then begin
// Если является, вывод её позиции на экран
writeln('Найдена буква “а”, ее позиция:' , i);
// и прерывание дальнейшего цикла, выход из него
break;
// Завершение блока "if"
end;
// Завершение цикла
end;
// Завершение программы
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота