davidmarabyan
29.05.2020 04:05

Напишите программу, реализующую игру на угадывание целого числа от 1 до 10. угадываемое число определяется случайно, пользователь вводит предполагаемое значение. если число угадано, программа выводит набранные очки, а если нет-предлагает повторить попытку. каждая безуспешная попытка снижает . в начале игры назначается 10 . , , составить сдать надо завтра.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
KeyTyan12345
27.08.2020 06:23
Var a,b,k,i:integer;
begin
b:=random(10)+1;
k:=10;
WriteLn('Привет, я задумал число от 1 до 10. Угадай его.');
while a<>b do
begin
Write('Введи число: ');
ReadLn(a);
if a<>b then
begin
WriteLn('Не угадал... Попробуй повторить попытку.');
k:=k-1
end
end;
WriteLn('Молодец! Угадал! Набранные очки: ',k)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота