Алёна542133
20.11.2021 21:17

Напишите программу в паскаль которая выводит квадраты первых 7 нечетных чисел в массиве

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
kadochkina061
08.10.2020 12:07
Не знаю как именно нужно было заполнять массив, поэтому сделал рандом
Var a:array[1..20] of Integer ;
n,i:integer;
Begin
n:=7;
WriteLn('Массив');
For i:= 1 to 20 do
begin
a[i]:=Random(20);
Write(a[i]:3);
end;
Writeln;
Writeln('Квадраты первых 7 нечетных чисел');
For i:=1 to 20 do
if (a[i] mod 2 = 1) and (n<>0)then
begin
Write(sqr(a[i]):4);
n:=n-1;
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота