mammedova75
12.04.2020 06:35

3.составить программу, которая устанавливала бы, является ли четырёхугольник со сторонами a, b, c, d параллелограммом. нужно

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
xawodilal
08.10.2020 11:31
Pascal :
Код чтобы скопировать : http://rextester.com/EFBKO81416

3.составить программу, которая устанавливала бы, является ли четырёхугольник со сторонами a, b, c, d
0,0(0 оценок)
Ответ:
Celestialess32
08.10.2020 11:31
Язык C++.
#include < iostream >
using namespace std;
int main(){
int a, b, c, d, u;
cout << "Все четыре угла прямые (Да - 1/Нет - 0)?" << endl;
cin >> u;
switch(u){
case 0:{
cout << "Введите длины сторон: " << endl;
cin >> a >> b >> c >> d;
if((a==c && d == b) && (a==b && c==d)&&(a==d && b==c) &&(c==b && a == d))
cout << "Не параллелограмм";
else if((a==c && d == b) || (a==b && c==d)||(a==d && b==c) || (c==b && a == d))
cout << "Параллелограмм";
else
cout << "Не параллелограмм";
break;
}
case 1:{
cout << "Не параллелограмм";
}
}
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота