C++. составьте программу, где вводят 4-значное натуральное число и переставляет его первую и последнюю цифру. например, 3456 должно получиться 6453

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
tolkacheva2005
08.10.2020 11:26
#include <iostream> 
using namespace std;
int main() {
 int n;  
 cin >> n;
 int a = n % 10, b = (n / 10) % 10, c = (n / 100) % 10, d = n / 1000;   
 cout << a * 1000 + c * 100 + b * 10 + d;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота