olya363
03.06.2021 19:05

9класс информатика дан целочисленным массив из 20 элементов, все элементы которого положительные числа , не превосходящие 100. напишите программу которая находит и выводит номер элемента , имеющего максимальное количество целочисленных делителей ( если таких элементов несколько, то номер любого из них). на паскале абс заранее

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ktvsl
08.10.2020 11:19
Const n=20;
var a: Array [1..n] of integer;
i,j,m,d,dm: Integer;
begin
for i:=1 to n do
a[i]:=random(100);
writeln (a);
for i:=1 to n do
begin
d:=0;
for j:=1 to a[i] do
if a[i] mod j = 0 then d:=d+1;
if d>dm then
begin
dm:=d;
m:=i
end
end;
writeln (m)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота