anonim198
17.04.2021 12:28

Дано трехзначное натуральное число. написать программу, которая определяет верно ли, что сумма цифр этого числа является нечетной ( число вводится с клавиатуры).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
akhdogru
08.10.2020 09:49
Var a,s:integer;
begin
 readln(a);
 s:=a div 100+a div 10 mod 10+a mod 10;
 if s mod 2=1 then writeln('Верно. s = ',s,' - нечётна')
 else writeln('Нет. s = ',s,' - чётна')
end.

Пример:
251
Нет. s = 8 - чётна
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота