cucheryavy
15.02.2020 14:14

Да ну трёх значные числа. напишите программу, который определяет: а) есть ли среди цифр заданного целого трёх значного числа одинаковый 123 нет 121 да 222 да б) является ли число перевертышем то есть число десятичной записи которые читаются одинаково слева направо и справа налево 122 нет 121 перевертыш 222 перевертыш

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
maxkov555p0chlb
08.10.2020 09:17
1.
var a,c:integer; m:set of 0..9; b:boolean;
begin
readln(a);
m:=[];
b:=false;
while a>0 do
 begin
 c:=a mod 10;
 if c in m then b:=true;
 m:=m+[c];
 a:=a div 10;
 end;
if b then writeln('Да')
else writeln('Нет');
end.

Пример:
121
Да

2.
var a,b,c:integer;
begin
readln(a);
c:=a;
b:=0;
while c>0 do
 begin
 b:=b*10+c mod 10;
 c:=c div 10;
 end;
if a=b then writeln('перевертыш')
else writeln('Нет');
end.

Пример:
121
перевертыш
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота