Войти
Регистрация
Спроси ai-bota
D3MON1
07.05.2023 19:12
Написать программу на паскале, которая будет считать сумму и среднее арифметическое 10 чисел, введенных массивом, используя процедуры или функции
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ru5829
01.07.2021 19:46
Определить произведение цифр в пятеричной записи десятичного числа 211...
Thelow26
03.05.2020 01:14
Какие современные решает теория кодирования?...
Эммикэт
01.04.2021 18:23
Во время исполнения програма хранение 1 в видеопамяти 2в оперативной памяти 3на жестком диске 4 пзу...
Yana12ost
01.04.2021 18:23
Напишите (паскаль)программу которая выводит на экран числа 20 40 80 160 320...
Мэри6669
09.03.2023 13:01
Один символ алфавита несёт 5 бит информации. какое максимальное кол-во символов может быть в алфавите?...
Yoyoy31231234
27.01.2020 22:25
Какие свойства есть у всех обьектов посуды...
casha201
28.08.2022 19:29
написать программы на pascal для решения 3х . 1.масса медвежонка составляет 15% массы белого медведя. найдите массу белого медведя, если масса медвежонка n кг? 2. на...
даданет
11.12.2021 18:26
Как выделить память для матрицы в которой 450 строк и 200 столбцов? в языке программирования си...
Августина1511
23.08.2020 03:44
Что можно считать информацией? 1) все что нас окружает 2) сведения о чем либо 3)звуки которые мы слышим 4) животные и растения 5) видеофильмы...
ksyushenkа
23.09.2021 07:45
Решите . объясните 4 и 5. найти значение суммы: 1)-10 + 7= 2)-4,6 + 6,6= 3)13,8 + (-5,2)= 4)7,14 + (-12,4)= 5)-4,8 + 4,8= 6)-1 + 0,329= 7)-5/14 + 7/10= 8)-8/15+1=...
Ответ:
Frapado
08.10.2020 08:34
//Язык Pascal
Program Test;
var
Mas: array[1..10] of integer;
result1: integer;
result2: real;
function Sum(): integer;
var summa: integer;
begin
summa := 0;
for var i := 1 to 10 do
summa := summa + Mas[i];
Sum := summa;
end;
procedure Arifmetic(r1: integer; var A: real);
begin
A := r1 / 10;
end;
Begin
for var i := 1 to 10 do
begin
Write('Введите ', i, ' элемент: ');
Readln(Mas[i]);
end;
result1 := Sum();
Arifmetic(result1, result2);
Writeln();
Writeln('Сумма = ', result1);
Writeln('Среднее арифметическое = ', result2);
End.
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота