kalaev19761
17.09.2020 01:48

Написать программу, определяющую сумму/количество элементов массива, кратных 3, но не кратных 5. на языке с++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
natsia
08.10.2020 07:13
#include <iostream>
#include <array>
#include <numeric>
using namespace std;

const size_t N = 10;

int main()
{
    size_t sum = 0;
    array<int, N> a = { 1, 5, 9, 6, 3, 0, 1, 4, -2, 15 };
    cout << "Count: ";
    cout << accumulate(a.cbegin(), a.cend(), 0, [&sum](size_t count, const int
num) {
                                                    if ( !(num % 3) && num % 5 ) {
                                                        ++count;
                                                        sum += num;
                                                    }
                                                    return count;
                                                });
    cout << " Sum: " << sum << endl;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота