erekeshevadinar
02.12.2022 01:42

Составить программу для вычисления квадратного уравнения x2+2x-3

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
mdotsenko
04.08.2020 13:15
var a,b,c,d,x1,x2: real;

begin
writeln('Введите коэффициенты a,b,c:');
readln(a,b,c);
d:=(sqr(b))-(4*a*c);
if d>0 then begin
x1:=(-b+(sqrt(d)))/(2*a);
x2:=(-b-(sqrt(d)))/(2*a);
writeln('');
writeln('x1= ',x1);
writeln('x2= ',x2);
end;
if d=0 then begin
x1:=(-b/2*a);
writeln('x= ',x1);
end;
if d<0 then writeln('Корней нет!');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота