oladushek2002oy6bqn
10.08.2020 13:42

Вданном массиве чисел найдите среднее арифметическое положительных элементов массива. составить программу для pascal abc

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ульяна122004
08.10.2020 06:42
var    
     arr : array[1..99] of integer;
     N, s, k : integer;
begin
    read(N);
    for var i := 1 to N do begin
        arr[i] := random(-10, 10);
        writeln(arr[i]);
        if arr[i] > 0 then begin
            s += arr[i];
            k += 1;
        end
    end;
    writeln(s/k);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота