maxim199431
22.03.2020 11:07

Составить программу, выводящую числа от 70 до 100, которые нечетные и делятся на 3. найти их сумму и количество этих чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
198206nh
08.10.2020 06:25
// PascalABC.NET 3.3

begin
  var a:=Range(70,101).Where(i->(i mod 2=1)and(i mod 3=0)).
     ToArray.Println;
  writeln('s = ',a.Sum,' k = ',a.Count);
end.

Результат:
75 81 87 93 99
s = 435 k = 5
0,0(0 оценок)
Ответ:
shkolnik1233
08.10.2020 06:25
C++
//g++  5.4.0

#include <iostream>
using namespace std;

int main()
{
    size_t sum = 0, count = 0;
    for (size_t i = 71, c = 1; i <= 100; i += 2, ++c) {
        cout << i << " ";
        sum += i;
        count = c;
    }
    cout << endl << sum << " / " << count << endl;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота