Maxxwell1
16.06.2021 11:58

Составить программу, которая создает и заполняет массив а из 7 целых чисел случайными значениями в диапазоне от 2 до 100. вывести массив на экран. определить количество элементов массива а, являющихся простыми числами. для определения, является ли элемент массива простым числом описать функцию, возвращающую логическое значение «true», если это простое число, и «false», если элемент массива не является простым числом

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
IUcenhik
08.10.2020 06:14
На скриншотах
0,0(0 оценок)
Ответ:
AlinaMalina1011
08.10.2020 06:14
var    
        A, num: array[1..999] of integer;
        k, kk: integer;

function SN(c: integer): boolean;
begin
        for var j := 2 to 9 do begin
            if c mod num[j] <> 0 then
                inc(k);
        end;
        if k = 8 then begin
            SN := true;
            inc(kk);
        end else if k <> 8 then
             SN := false;
        k := 0;
end;

begin
    for var i := 2 to 9 do
         num[i] := i;
    for var i := 1 to 7 do begin
         A[i] := random(2, 200);
        writeln(A[i] + ' ');
        writeln(SN(A[i]));
    end;
    writeln(kk);
end.

Составить программу, которая создает и заполняет массив а из 7 целых чисел случайными значениями в д
Составить программу, которая создает и заполняет массив а из 7 целых чисел случайными значениями в д
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота