nikolasosadchey
19.03.2021 23:33

Вывести квадраты чисел от 1 до n. в паскале написать программу (не используя for)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
рами0208
08.10.2020 05:40
1)
// PascalABC.NET 3.3

begin
  var n:=ReadInteger('n =');
  Range(1,n).Select(i->i*i).Println;
end.

Пример:
n = 5
1 4 9 16 25

2)
var n,i: integer;
begin
write('N = ');
readln(n);
i:=0;
while (i<n) do
 begin
 i:=i+1;
 write(i*i,' ');
 end;
end.

3)
var n,i: integer;
begin 
write('N = ');
readln(n); 
i:=0; 
repeat
 i:=i+1;
 write(i*i,' '); 
until i=n;
end.

Пример:
N = 5
1 4 9 16 25
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота