snagaytsev1
03.08.2021 15:52

Написать программу, которая запрашивает массив из n элементов, а затем делит все элементы массива на минимальный элемент. протестировать программу на пассивах размерностью 5 и 10 элементов.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ivchencov767
08.10.2020 05:33
Программа со статическим массивом:

Var
  M: array[1..32767] of real;
  Min: real;
  N, i: integer;
Begin
  Write('N = ');ReadLn(N);
  if (N <= 0) then
    WriteLn('Количество элементов должно быть положительно')
  else
  begin
    Write('Введите элементы массива в количестве ',N,' штук');
    For i:= 1 to N do
      Read(M[i]);
    Min := M[1];
    For i:= 2 to N do
      if (M[i] < Min) then
        Min := M[i];
    WriteLn;
    Write('Получившийся массив:');
    For i:= 1 to N do
    begin
      M[i] := M[i] / Min;
      Write(' ',M[i]);
    end;
  end
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота