zLimboz
14.10.2021 02:31

Составить блок-схему и написать программу для проверки того, что в сумма цифр некоторого числа равна 10

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Dаniеll
08.10.2020 05:31
Замечание: предполагается, что вводятся натуральные числа.
Блок-схема - в прилагаемом файле.
var a,s:integer;
begin
readln(a);
s:=0;
while a>0 do
 begin
 s:=s+a mod 10;
 a:=a div 10;
 end;
writeln('s = ',s);
if s=10 then writeln('s = 10')
else writeln('s <> 10');
end.

Пример:
527
s = 14
s <> 10
Составить блок-схему и написать программу для проверки того, что в сумма цифр некоторого числа равна
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота