Даны натуральное число n (< 50) и числовой массив а[1..n]. составить программу, которая определяет сумму минимального элемента множества {а1; а3; } и максимального элемента множества {а2; а4; }.
// PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018 // Внимание! Если программа не работает, обновите версию!
begin var n:=ReadInteger('n='); var a:=ArrRandom(n,-99,99); a.Println; var minOdd:=Range(0,n-1,2).Select(i->a[i]).Min; var maxEven:=Range(1,n-1,2).Select(i->a[i]).Max; Writeln('Искомая сумма равна ',minOdd+maxEven) end.