Милкович11
18.10.2022 10:22

Напишите программу на языке паскаль для решения дано четырёхзначное число х. найти: a. число десятков в нем; b. число единиц в нем; c. число сотен в нем; d. число тысяч в нем; e. сумму его цифр; f. произведение его цифр.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Chika200616
16.08.2020 19:20
Uses crt;
var input, betw:integer;
begin         
readln(input);                  
betw := input;          
betw := betw div 10;         
betw := betw div 10;         
betw := betw div 10;
      
writeln('Тысяч = ', betw); 
                
betw := input;         
betw := betw div 10;         
betw := betw div 10;         
betw := betw mod 10;                  
writeln('Сотен = ', betw);                 
betw := input;         
betw := betw div 10;         
betw := betw mod 10;                  
writeln('Десятков = ', betw);                           
betw := input;         
betw := betw mod 10;                  
writeln('Единиц = ', betw);        end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота