daniyabekzhan1
27.03.2023 10:46

Дан массив 12 чисел. вывести числа в порядке возрастания. написать программу pascal abc .

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Salahaddin001
08.10.2020 03:11
Const n=12;
var
  a:array[1..n] of integer;
  i,j,t:integer;
begin
  Randomize;
  Writeln('Исходный массив:');
  for i:=1 to n do begin
    a[i]:=Random(51)-25;
    Write(a[i],' ')
  end;
  Writeln;
  for i:=1 to n-1 do
    for j:=1 to n-i do
      if a[j]>a[j+1] then
      begin t:=a[j]; a[j]:=a[j+1]; a[j+1]:=t end;
  Writeln('Отсортированный массив:');
  for i:=1 to n do Write(a[i],' ');
  Writeln
end.

Пример:
Исходный массив:
-6 -11 -1 -24 -15 23 14 -13 -5 3 17 -21
Отсортированный массив:
-24 -21 -15 -13 -11 -6 -5 -1 3 14 17 23
0,0(0 оценок)
Ответ:
juliabatrukova
08.10.2020 03:11
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(12,-99,99);
  a.Println.OrderBy(t->t).Println
end.

Пример
56 -46 -48 87 31 6 -33 -66 32 20 6 40
-66 -48 -46 -33 6 6 20 31 32 40 56 87
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота