света8612
12.11.2022 11:28

Мне нужно написать программу, чтобы она высчитывала количество досок на забор, но есть условие, где если у=0, то v=p/d, иначе v=p/d+1.

у-остаток

v -общее количество досок

p - периметр участка

d - ширина доски

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Vexicy
04.03.2022 02:50
Program z3;
const n=3;
var A:array[1..n] of string;
var B:array[1..n] of string;
i,k:byte;

begin
writeln('Ввод названий газет:');
for i:=1 to n do
 begin write('[',i,'] '); readln(A[i]);end;
writeln('Ввод фамилий подписчиков:');
for i:=1 to n do
 begin write('[',i,'] '); readln(B[i]);end;
k:=0;
for i:=1 to n do
 if (A[i]='Правда') and (B[i]='Петров') then k:=i;
if k<>0 then writeln('Да, Петров выписывает Правду.')
        else writeln('Петров не выписывает Правду.');
end.

Пример:
Ввод названий газет:
[1] Правда
[2] Мир
[3] Атеист
Ввод фамилий подписчиков:
[1] Петров
[2] Дружаев
[3] Базаров
Да, Петров выписывает Правду.
0,0(0 оценок)
Ответ:
elizabetas326
04.03.2022 02:50
Program z3;
var A:array[1..3] of string;
var B:array[1..3] of string;
i,k:byte;
begin
writeln('Ввод названий газет: ');
  for i:=1 to 3 do begin write('[',i,']');readln(A[i]); end;
writeln('Ввод подписчиков: ');
  for i:=1 to 3 do begin write('[',i,']'); readln(B[i]); end;

for i:=1 to 3 do begin
  if (A[i]='правда') and (B[i]= 'петров') then begin k:=i;
  writeln('Да, Петров выписывает газету ',A[i]); end;
 end;
end.

Ввод названий газет: 
[1]Книга
[2]Правда
[3]Вера
Ввод подписчиков: 
[1]Библиотекарь
[2]Петров
[3]Гундяев
Да, Петров выписывает газету Правда
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота