Войти
Регистрация
Спроси ai-bota
ГхмГхм
28.07.2022 17:54
Дан двумерный массив. определить, есть ли среди элементов массива данное число q. написать программу, . заранее : )
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
ДжузоСузуя13
31.05.2022 00:00
Вкаком ответе сообщение написано с использованием формального языка? a) белеет парус одинокий … b) my name is john c) f = mg d) информатика - наука, изучающая информационные процессы...
golgotha
25.05.2023 19:33
Составить программу вычисления, w = b + a - сумма положительных элементов массива; b – номер наименьшего элемента массива; c - количество элементов массива кратных пяти. полученные...
Alex90111
01.04.2022 02:07
Каким образом можно увеличить расстояние между абзацами не меняя расстояние между строками в самом абзаце...
alicekuznetsova
23.09.2022 20:11
Сполным решением .в классе 1111 девочек и 1010 мальчиков. ( числа 1111 и 1010 в десятичной системе счисления) сколько всего человек в классе?...
Sharю
05.12.2021 22:02
Сели за круглый стол и стали играть в игру: 1) каждый получил номер по порядку; 2) начиная с первого они рассчитались на «первый», «второй»; 3) каждый второй встал и вышел из игры;...
gagikgrigoryan
15.01.2020 17:53
Решите уравнение: 25.(х + 13214) = 11с16 полученный результат выразите в десятичной системе. чему равна сумма цифр полученного числа?...
АндрейДемаков
30.03.2022 12:09
Иван и саша вырезали из белой бумаги четыре ёлочки разных размеров.сколькими можно покрасить вырезные ёлочки в серебристый и зелёный цвета, если количество краски не ограничено ,...
svyara8
24.02.2020 12:25
2048 байт= кбайт 10 мбайт= кбайт 3072 мбайт= гбайт 10 бит= байт 32 байта= бит...
FireStreamGun
24.02.2020 12:25
:написать программу, вычисляющую произведение элементов одномерного массива z(n). рекомендация: посмотрите алгоритм нахождения суммы и обратите внимание на то, что произведение p:...
supernogai
09.12.2021 02:47
Высветилось сообщение от адобе флеш плеер и кнопки на выбор обновить или установить . моя дочь нажала обновить , пошла загрузка, загрузился амиго и ещё что-то, и она сразу же нажала...
Ответ:
ФархадАсланов
08.10.2020 02:19
// PascalABC.NET 3.3
const n=7;
begin
Writeln('Исходный массив:');
var a:=MatrRandom(n,n,-10,10); a.Println(6);
var q:=ReadInteger('q = ');
var m:=a.ElementsByRow.Where(x->x=q).Count;
if m>0 then writeln('YES') else writeln('NO');
end.
Пример:
Исходный массив:
0 -1 -10 7 5 5 5
-3 8 8 -8 4 10 0
-2 9 -1 -4 -10 -2 2
-9 6 10 -4 3 -5 4
-3 9 4 -6 8 10 -2
4 -1 -2 8 9 -8 -3
5 6 2 5 9 3 8
q = 9
YES
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота